, , ,

Whenever I encountered a problem, it always helps if I just go to sleep and continue doing it the next morning, with a fresher mind.

I was stuck trying to get the ATmega chip to work on Gertboard and to upload the Arduino sketch onto it. They failed me with 2 sets of error messages:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override this check

This can be solved by erasing the chip first: (thanks to one of the Gordon’s comments)

avrdude -c gpio -e

The other error:

avrdude: verification error, first mismatch at byte 0×0000
0x0c != 0×00
avrdude: verification error; content mismatch

ATmega device on Gertboard operates at 3.3V. Therefore it is important to send the 3.3V power supply to the those Gertboard components. This can be solved by placing a jumper over the pin 1 and 2 on j7 as mentioned in the Manual:

To send the 3.3V power supply to the components on the Gertboard, you need to install a jumper over the top two pins of the header J7. It is near the lower right corner of the board;

jumper over j7

Put a jumper over Pin 1 and 2 on J7

Now I can upload the Arduino Basic Blink test to my Gertboard! I connected a jumper wire from PB5 (pin13 for Arduino) to BUF1, and the LED starts blinking 🙂

Connect PB5 to BUF1

Connect PB5 to BUF1